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A note about QGIS versions 
This workbook was written for QGIS version 3.10.13, the latest long-term release (LTR). If any 
screenshots in the workbook look different to the ones on your screen it is probably 
because you’re on a different version, or have your toolbars positioned differently, but this 
is unlikely to cause any problems. Most QGIS versions are named after where the 
developers have their meetings (e.g. 3.10 is called A Coruña). The LTR version of QGIS is the 
most stable one, but you will also see a newer version of QGIS on the website – these often 
have more features but are not yet finalised for official long-term release.  
 
 
This workbook is also available online, at: 
https://automaticknowledge.org/training/workbooks 
 
Licence: Attribution-Non Commercial 2.0 Generic (CC BY-NC 2.0) 
https://creativecommons.org/licenses/by-nc/2.0 
 

   

https://automaticknowledge.org/training/workbooks
https://creativecommons.org/licenses/by-nc/2.0
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About Automatic Knowledge 
Our philosophy is all about sharing data 
and knowledge, so that we can all be a bit 
better informed about the world. The way 
we do this is mainly through spatial data 
analysis and visualisation, and as part of 
this we offer training courses in geospatial 
software – mostly QGIS. Alasdair Rae 
(pictured) founded Automatic Knowledge 
in 2019 and also runs the training courses.  
 
Why ‘automatic knowledge’? 
The idea behind Automatic Knowledge is that we do the hard 
work of completing the journey from data to knowledge, so that 
you can then make more informed decisions. These training 
sessions will hopefully help you do that too. 
 
Other activities (e.g. free stuff) 
In addition to training, we provide a range of consultancy 
services, specialising in data, spatial analysis, the built 
environment and cartography. We also publish free and open 
datasets that you may find useful, at: 
 
automaticknowledge.co.uk/resources  
 
We’re also a ‘sustaining member’ of QGIS, which means that we 
donate money to the QGIS project on an annual basis, to help 
fund its development. By taking this course, you’re helping too. 

https://automaticknowledge.co.uk/resources
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Automatic Knowledge training sessions 
The idea behind all our training sessions, and these workbooks, 
is to help you learn new things in an enjoyable way, without 
confusing you. We want everyone who takes one of our courses 
to come away with useful new skills that they can then put into 
practice in their day-to-day work, and build on in the future. 
 
About this workbook 
Following a workbook can be a great way to learn new software 
skills, but there’s also a risk that it turns us into robots, following 
step-by-step instructions in a linear way. During the session 
we’ll go off at tangents and do some demos of useful skills – 
among other things. The emojis? I add them in for a bit of colour, 
but they also serve a practical purpose because they can help 
us find key sections of the document quickly. 
 
Formatting 
Most font is size 14. When switching between screen and 
workbook this is easier on the eyes. The following format will be 
used in relation to files/folders, websites, QGIS options/tools, 
click actions and any text I want you to input. I’ve also added a 
‘Notes’ section on each page where you can jot things down. 
 
Files, folders and suchlike: e.g. world_countries.shp 
Websites: e.g. www.automaticknowledge.org/training 
QGIS windows, tools, sections, options: e.g. Coordinate 
Actions - click menu item/ button: e.g. Vector > Research Tools 
Text input: e.g. "roadClassificationNumber" = 'M8' 

http://www.automaticknowledge.org/training
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1. Introduction 
This training session is all about taking QGIS to the ‘next level’. 
What is this mysterious ‘next level’? Well, here’s what I’m thinking. 
 

 You learn how to do exciting new stuff. 
 You learn things that will make you more productive. 
 You learn how to ask questions of your data. 
 You learn how to answer those questions. 
 You end up thinking of new questions. 
 You push yourself, even getting a bit confused. 
 You move beyond confusion, to new understanding. 
 You come away with useful new skills. 
 You end up making more meaningful maps. 
 You impress your colleagues with your new skills. 

 
The expectation is that you’re already a proficient QGIS user and 
that you understand at least a bit of the fundamentals of how 
geospatial software works. That is, you understand that it’s not 
just about making maps, even if maps do usually end up being 
the end result.  
 
With that in mind, this training lesson doesn’t follow as much of 
a step-by-step format as our intro-level QGIS course. We’ll do 
some of the step-by-step stuff but we’ll also do more live demo 
follow alongs, as well as set tasks and going off at  
 
We’re mainly going to use global data and UK data today, for 
different purposes. We’ll also create some new data. 
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The map above? We’ll make this ourselves soon and we’ll do all 
kinds of interesting things, but the main things I want you to 
learn from today are as follows. 
 

1. How to use geometry generators in QGIS. 
2. How to use the vector geoprocessing tools. 
3. How to create/edit new data in QGIS. 
4. How to use the Processing toolbox in QGIS. 
5. How to use Plugins. 
6. How to automate map production with QGIS Atlas. 

 
The last of these is the most significant and will probably take 
up the most time – it’s also the most impressive and useful once 
you get to grips with it.  
 
But first, let’s grab the data and make a population spike map. 



Taking QGIS to the Next Level                      automaticknowledge 

6 
 

Notes 

Go to https://automaticknowledge.org/training/data/ and 
download datasets 1 to 8.  
 
You may already have datasets 1 to 4 if you’ve previously done a 
session with us, but either way please download these files 
individually and put them into a folder for today’s session – and 
make sure you know where you’ve saved them to! 
 
The file names should be self-explanatory but here’s a summary 
of the files we’ll be using today: 
 

1. A world countries layer (as a GeoPackage). 
2. A world countries layer (as a shapefile). 
3. A world cities csv (this is just a text file). 
4. A World Bank country population dataset (an Excel file). 
5. A Great Britain places layer. 
6. A Great Britain motorways layer. 
7. A Great Britain small area population data layer. 
8. A UK local authority boundary layer (with population data). 

 
 Start QGIS now so that we can get going in a moment. 

 
We have point layers (GB places, GB population data), line 
layers (GB motorways), polygon layers (countries in two GIS file 
formats, UK local authorities) and two datasets with no 
geometry at all (the cities csv file and the country population 
dataset). These are some of the basic file types in GIS. 
  

https://automaticknowledge.org/training/data/
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2. When is a polygon not a polygon? 
We know that in GIS, when we’re talking about vector-based 
data, everyone talks about features in relation to points (e.g. 
cities), lines (e.g. roads) and polygons (e.g. countries), as I just 
said. This makes sense, but with QGIS we can actually make a 
polygon into a point, or a point into a line, or all sorts of other 
combinations. 
 
Let’s look at this now with an interesting example. 
 

When you see this symbol, it’s time to follow what I’m 
doing on screen, so with that in mind, let’s get started. I 
will add text and screenshots for reference, but I won’t 

do the same level of step-by-step instructions that you’d get in 
the intro-level workbook. Interrupt me, ask questions if needed. 
 

 First we’ll add the 1_world_countries.gpkg file to QGIS – 
remember that as well as adding this via the Data Source 
Manager, you can just drag and drop it into QGIS directly 
from your system’s file browser – that’s how I usually do it. I 
can’t abide looking at ugly colours, so I’ll change that 
straight away! Open Layer Styling panel quickly with . 
 

 Then we’ll add the 3_world_cities.csv file. This is just a text 
file so we’ll need to do this via the Data Source Manager 
and then the Delimited Text option.  
 

 Okay, so now we have lots of dots and lots of land. 
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Soon we’re going to filter the dots and then use a geometry 
generator in QGIS to create vertical lines – the height of the 
vertical lines is going to be set based on the population of the 
points in this layer. Read on below for how to achieve this. 
 
The geometry generator in QGIS is a way of displaying one kind 
of data as another – e.g. a point as a line, or a polygon as a 
point. But you can also use it in other ways, such as creating 
buffers. In fact, you can do just about anything with it but since 
we’re only getting started we’ll keep it simple for now. 
 

 Filter your cities layer so you’re only showing world cities 
with a population of 250,000 or greater. 

 
 Use the text  below with Geometry generator (LineString / 

MultiLineString), instead of Simple marker, to generate our 
spikes (copy and paste this from the pdf if you like): 

Hey, where do I find the Geometry generator? It’s in the style for a layer. Select 
‘Simple marker’ or ‘Simple fill’,  then where it says ‘Symbol layer type’, change it to 
‘Geometry generator’, make sure the Geometry type matches what you are trying 
to create (e.g. lines, points, polygons) and then the expression goes in the whitebox. 
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make_line($geometry,make_point(x($geometry),y($geo
metry)+  ("population" /1000000) )) 
 

Ok, let’s take a second to step back and figure out what’s going 
on. The make_line function tells QGIS to make a line from the 
points we have plotted. It does this at the x and y coordinates of 
each point (that’s what the x($geometry) and y($geometry) 
bits do). But that would essentially be a line of length 0 and 
would be invisible. No spike map yet? Just ask for help. 
 

 Where it says ("population" /1000000) delete this portion of 
text, including the brackets, and type in 100 after the plus 
instead. This will make every spike 100 map units high (the 
map units here are degrees, as in degrees of lat or long). 
 

 Put the ("population" /1000000) bit back in and instead of 
dividing by 1 million, change the figure to 500000. We’ll try 
different numbers here too just so you can see what’s 
going on. We just use a number here to scale the spikes. 
 

 Let’s clear the Filter on the layer and then have a play 
around with the Symbology and do things like style by 
country or by population. 
 

 Let’s try a layer Filter so we’re only showing one country 
and then zoom in and see what it looks like. After that we 
can clear the Filter and go back to full view. 
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Time to save your work 
It’s a good idea to save your work regularly as we go through this. 
I recommend saving the project now as qgis_next_level_p9 and then 
saving as a new project with a different page number as you go through. 
That way you can go back to earlier parts and are okay if distaster strikes. 

 
Okay, so this can be quite good fun. But it can also be useful. 
Let’s say you have a layer that has many different parts (e.g. 
countries) but you want to show it as one big area (e.g. just one 
big landmass with no borders).  
 
You can do this with a geometry generator as well. 
 

 We’ll turn off the population spikes layer now and make 
sure that we can see country borders in the 
1_world_countries layer. 

 
 Let’s try this in the geometry generator for the countries 

layer: buffer(collect($geometry),0). What does this do? It 
dissolves all countries into one single polygon. 
 

Remember this 
The geometry generator tools in QGIS can be immensely useful. 
 
But, if you’re working with complex geometries with thousands or millions 
of vertices – e.g. a high resolution coastline file from Ordnance Survey – 
then it may not be a good way to do it (too computationally demanding). 
It’s best to use this approach on features with fewer vertices, if possible – 
but if you have a powerful computer it shouldn’t be a problem. 
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 Let’s Filter so we’re only looking at the United Kingdom now 
and try some of the following: 

 
simplify($geometry,0.5)  
 
buffer($geometry,0.5) 

 
And then we can try tweaking 
things here – and look in the 
Geometry section of the 
Expression Dialog. We just 
need to ensure that the 
Geometry type matches what 
we’re trying to achieve. 
 
Time to save your work 
I recommend saving the project now as qgis_next_level_p11 and then 
saving as a new project with a different page number as you go through.  
 
I won’t add in this Save box again but I’ll add the Save icon from time to 
time as a reminder. This kind of incremental saving is really useful and 
each QGIS project file of this kind will only take up a tiny portion of space on 
your hard drive – this one I just saved only takes up 16.7KB. 

 
We can also use a geometry generator without typing anything 
in at all. For example, from the countries layer we could just 
show country centroids as points – like in the screenshot on the 
next page (I have the normal country polygon layer on too). 
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If you want to try this, remember to remove the layer filter first. 
 
Okay, so you get the idea. 
 
It’s quite easy to generate one kind of geometry from another in 
QGIS, and it can be used to achieve some interesting and useful 
results (you could also use the above example for label 
placement) 
 
The internet can be a confusing place, so if you want to learn 
more about this, I recommend the following two links. 
 
Klas Karlsson - https://www.youtube.com/watch?v=0YxjJ-9zIJ0 
 
Hamish Campbell - https://polemic.nz/2019/11/18/foss4g-qgis-
geometry-generators 

These options can 
be very useful. 

https://www.youtube.com/watch?v=0YxjJ-9zIJ0
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3. Going deeper with geoprocessing in QGIS 
Make sure you’ve saved the QGIS project from the previous 
page (e.g. as qgis_next_level_p12) and then open a  new 
project in QGIS.  
 
In this part of the workbook we’ll look at data from the UK, mostly 
covering Great Britain. 
 

 First of all, let’s add in datasets 5 to 8. They are all 
GeoPackages and you’ll notice that they are pre-styled. 
 

 Let’s take a small detour to explore this styling – things like 
the scale dependent rendering, labelling, use of 
expressions to set symbol sizes and that kind of thing. I’ll 
also explain how I saved these styles into the layer as well. 
 

 Your layers should display in order from 5 at the top to 8 at 
the bottom, but if not just rearrange them in the Layers 
Panel so that 5 is at the top, followed by 6, 7 and 8. 
 

 We’re going to zoom in to the M25 area – for anyone not 
familiar with it, this is the motorway that encircles Greater 
London. 
 

 Let’s save this zoomed view as a Spatial Bookmark (View > 
New Spatial Bookmark…) and then zoom back out to view 
the whole layer again. Let’s select and zoom to the M62 
and save another Spatial Bookmark for that. And the M8. 
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In QGIS, as with most software programmes, there are multiple 
ways of doing the same thing.  
 
You may already have noticed that I do some things differently 
from you, and that’s fine. Just do what works best for you. 
 
The same applies to geoprocessing in QGIS. We can do it via the 
Processing Toolbox (we’ll look at that later) or via the Vector 
menu – which we’ll do in a moment or two. 
 
For the next little while we’re going to be working via the Vector 
menu, using the following sub-menus: 
 

 Geoprocessing Tools 
 Research Tools 
 Analysis Tools 

 
 
N.B. We’d like to have data for Northern Ireland but because 
Ordnance Survey data only covers Great Britain we don’t have 
complete UK coverage. 
 
With geoprocessing we’re able to ask, and answer, quite 
interesting and often complex geographical questions. 
 
We’re going to crowdsource some questions from the group 
now, but I’ve added some questions below to get us started. 
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How many people live within 100 miles of Norwich? 
 
 
How many people live within 10 miles of the M25? 
 
 
How many local authorities have a motorway? 
 
 
How many people live within 30 miles of Birmingham? 
 
 
…let’s add more (as bizarre or boring as you like) – once we’ve 
got enough questions we’ll go to the next page. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Hopefully you’re following this – if not, let me know. 
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Okay, let’s try the ‘how many people live within 100 miles of 
Norwich?’ question. We’ll ignore any non-English bits. To answer 
this, here’s what we’ll do in a few moments – you can follow 
along as I do it (the list below is the basic workflow). 
 

1. Select Norwich from the places layer. 
2. Create a 100 mile buffer round Norwich. 
3. Select all the population points within the buffer. 
4. Use a tool to find out the total population. 

 
Is the answer that 15 million people live within 100 miles 
of Norwich? Could it be true? Let’s find out. 
 

 

First, make sure the 
places layer is 
selected in the 

Layers panel on the 
left of the screen. 

Then we can select 
Norwich from the 

places layer. 



Taking QGIS to the Next Level                      automaticknowledge 

17 
 

Notes 

 Then it’s Vector > Geoprocessing Tools > Buffer… and then 
using only the selected feature in the places layer, 50 
Segments, and 100 miles. We could have chosen to save 
the Buffer to a new layer but I don’t need to this time so it 
will appear as a ‘scratch’  (temporary) layer only. 

 
 Now you have your Norwich Megaregion! Then we’ll want to 

use Vector > Research Tools > Select by Location… to Select 
features from the small area population layer that are 
within the Norwich buffer. See below for how this looks, and 
note that there are many geometric predicate options we 
can use in different situations. Then Run and then Close. 
 

 Then Vector > Analysis > Basic Statistics for Fields… on 
Selected features only of the small area population layer, 
using POP2019 as the Field to calculate statistics on.  
 

 

N.B. Once you’ve clicked Run you can then click Close. After running 
Basic Statistics for Fields you’ll see the results – looks complex, but it 
just contains y summary stats – see ‘Sum’ for the total figure, but you 
also get count, max, min, mean, std dev and so on. 

Just pay close 
attention to the 

options here – it’s 
easy to make a 

mistake. Then you 
can Run and Close. 
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Top tip 
Need to re-do any of your geoprocessing tasks in QGIS?  
 
If you need to re-run a tool in QGIS, instead of going back through all the 
menus and options you can instead go to Processing > History and then 
reload your query from the list and change your parameters if you need to. 
 
It’s REALLY useful, even if it does look a bit like a nerdfest. 

 
 Using the Processing > History option let’s re-run the Buffer 

analysis but this time based on population within 100 miles 
of London. Woah, that’s a big number. 30 million?!? 

 
If there’s time, let’s try one more of these together and then you 
can work away on others on your own. 
 

 Zoom to the motorways layer by selecting it in the Layers 
panel on the left and then hitting  Zoom to Layer. 

 
 Then we’re going to use Vector > Research Tools > Select by 

Location… to Select features from the local authorities layer 
(8) By comparing to the features from the motorways 
layer, using the intersect predicate. Then we hit Run to see 
the result (in the lower left of the QGIS window, or open the 
Attribute Table and look at the top of that window). 

 
Now have a go at some of the other questions from before, or 
even add some of your own. No question is too weird. You could 
even select multiple cities and buffer them simultaneously. 
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Baffled? 
Wondering why we’re doing this? That’s a good thing to ask. 
 
Let’s say the government want to widen the M1 to 5 lanes each way (eek) – 
they’re going to want to find out pretty quickly what local authorities are 
affected and how many people might be impacted. This is can be done 
quickly and efficiently using spatial analysis. 
 
Or maybe you have to decide between three locations for the site of a new 
nuclear power station that will be there for 100 years. You can be sure that 
some form of spatial analysis – among other things – will come in handy. 
 
These are just basic examples, but the fundamental underlying issue here 
is the ‘what’s nearby?’ question, and with spatial analysis we can do this by 
distance like we have done, or by time, using tools like TravelTime Platform 
(an excellent QGIS plugin). 

 
As you know, this course is aimed at current QGIS users but even 
those who use QGIS a lot can still find it difficult to remember 
what’s what and what’s where. 
 
As you’re going through this, remember the two main Select 
buttons – using a click/drag/draw or by expression, plus the 

Deselect Features from All Layers button. . 
 
Remember this 
The population data we’re using is from mid-2019. 
It’s the latest small area data, using population-weighted LSOA (Eng & Wal) 
or data zone (Sco) centroids. There will inevitably be a little bit of mismatch 
at buffer boundaries, but the figures you get will be good approximations. 
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4. Creating and editing spatial data 
Being able to create new data is a great skill to have and in QGIS 
it’s really simple – though it doesn’t necessarily appear that 
way. 
 
Remember this 
You might see the term ‘scratch layer’ in QGIS quite a bit. 
What is a ‘scratch layer’? Here’s the definition from the QGIS help text: 
 
‘Temporary Scratch Layers are in-memory layers, meaning that they are 
not saved on disk and will be discarded when QGIS is closed’. 
 
When I’m doing geoprocessing analysis and only need the final figures 
rather than any buffer layers, I may choose not to save them as permanent 
layers. But just remember than any scratch layers you use in a QGIS project 
will disappear when you close it – even if you save the project. 

 
 Make sure you’ve saved the project with the UK data in it 

and then open a fresh, blank project. 
 

 Let’s start by creating some data from some text – kind of 
like we did before with the csv file, but even simpler. Copy 
the text below into a basic text editor on your computer 
(e.g. Notepad or TextEdit), save it as a text file and then 
import to QGIS using the Delimited Text tool. 
 
name,geom 
equator, "LINESTRING(-180.0 0.0, 180.0 0.0)" 
prime meridian, "LINESTRING(0.0 90.0, 0.0 -90.0)" 

I put this in the 
data folder – 
wkt_text.txt 
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Now I’m going to explain what just happened and then 
we can all follow along: 
 

 
Next steps – I’ll do them now, for you to follow, via the Vector 
menu: 
 

 We’ll add the countries GeoPackage to the map. 
 We’ll use Create grid (V>R) to create a 10 degree world grid. 
 We’ll use Densify by count (V>Geom) (using 1000) so that 

our grid can be wrapped round a globe. 
 We’ll change the projection to The_World_From_Space. 

We could also try the Globe Builder plugin if we have time – 
this is more likely to look perfect. It was created by Gispo 
Ltd, from Finland and I think it’s really great. 

 
Look at the next page for an example of what I just produced 
(using Globe Builder), with my globe centred at -30, 40. 

Well, this is exciting! 



Taking QGIS to the Next Level                      automaticknowledge 

22 
 

Notes 

 
The grid on the globe is one we created from text, based on our 
original import of the wkt text file.  
 

 Let’s change the projection back 
to WGS84. 

 Now follow along as I create 
Atlantis and talk a bit about 
creating new vector layers.  

The basic process for creating a new layer is Layer > Create Layer > 
New Shapefile Layer (or > New Temporary Scratch Layer). Then 
select the geometry type (e.g. point, polygon). Then in Edit mode you 
use the editing tools to draw/place the new points, lines or polygons. 
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If we have time, let’s try a bit of data crowdsourcing. I’m going to 
save a small text file where we have a name, latitude, longitude 
for all of us. Here’s the first and second rows. 
 

Name,lat,long 
Alasdair, 53.3956347,-1.6395383 
 

I just need everyone to share with me a single line of text with 
their name then the lat/long of their location (I don’t need your 
exact location, just the general area). Get the lat/long with a 
right-click straight off Google Maps or Bing Maps. 
 

So, if your name is Dolly, please send me this: 
 

Dolly, 35.797270, -83.533870 
 

I’ll then patch them all together, share the text and then we can 
map where we all are. It should only take a few minutes. 
 
Top tip 
Need to include a brand new building in your GIS analysis? Hmm.  
 
The only problem is that has not yet been mapped. I had this problem 
when I needed to map the new Tottenham Hotspur stadium in London. It 
wasn’t yet included in the Ordnance Survey data (it is now) so I had to 
create it. I added a satellite XYZ base layer to QGIS and then created a new 
polygon shapefile and digitized it myself – just as I did for Atlantis above, 
exactly the same principle - just at a different spatial scale. 
 
When you create a new layer, just be sure you choose the correct 
geometry type – either point, line or polygon feature. 
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5. The Processing Toolbox 
Make sure you’ve saved the project from the previous page – 
and remember to keep saving it with the file name in the project 
in case you need to go back to it. I just saved mine as 
qgis_next_level_p23, and it takes up only 19.2KB of disk space 
so there’s really no reason not to use this kind of incremental 
save – even if it does create a few more files for you.  
 
We’re going to take a closer look at the Processing Toolbox in 
QGIS now. It can be confusing, but once you know where to find 
it and what it does, you’ll have opened a whole new world. 
 

 Open a New project if you haven’t already. If it’s not already 
visible, activate it now via Processing > Toolbox and then 
dock it to the right of your screen by grabbing it and then 
dropping it when the right panel area is highlighted blue – 
sounds confusing but I can demo if need be.  

 
You can see what mine looks like on the next page, but what 
exactly is it? I always describe it as the gateway to geospatial 
analysis in QGIS. You can perform many tasks in QGIS via 
menus, but what you get here is many ways of doing things, 
from different tool and algorithm Providers. That is, in addition to 
the in-built QGIS tools, we can also access other geoprocessing 
tools from (e.g.) SAGA, GDAL and GRASS.  
 
If you search for buffer in the search bar you’ll see buffer tools 
from these different providers. 
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We can do other 
things from here – 
like Python scripts 
and models – but 
we won’t go into 
that today. 
 
I normally have my 
Processing Toolbox 
on all the time 
because it’s so 
useful and I do so 
much spatial 
analysis with the 
tools in it. 
 
Another reason to 
use it is because 
you don’t have to 
remember which 
menu things are in 
– e.g. if you want to 
use Basic statistics 
for fields, just type it 
in to the search 
box. 
 
 

You can see that I’ve 
recently been using 

these tools – this 
Recently used list is 

super useful. 
 

And if you hit the 
little  clock 

History icon at the 
top, above the 

search bar, you can 
re-run previous 

algorithms. 

Note that I’ve docked quite a few things 
here and they can be accessed via 

these tabs. 
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Let’s run through some tools using datasets 5 to 8. We’ll 
begin with the following tasks – you can follow along – 
and then you can experiment further yourself. 
 

 We’ll create a Bar plot of motorway lengths. 
 

 We’ll do a Select by expression here (on the M1). Then we’ll 
do an Extract by location (intersect), extracting features 
from 8_UK_LAD_with_population that intersect the M1. 
 

 Then use Basic statistics for fields on the popmid2019 field 
 

 Then we’ll use another Extract by location (intersect) on the 
new layer we created above – this time a point in polygon 
operation to extract places from the 5_GB_places layer. 
 

 We’ll use Interpolation to create a Heatmap using our 
population density layer – using a 10km radius, 1000m X 
and Y Pixel size and POP2019 as the weight. 
 

 Let’s try the Extract layer extent tool too – that can be 
useful (we can add buffer($geometry,100000) to it). 
 

 Let’s use the Dissolve tool now – a good example of where 
there are several options (we’ll use the QGIS default). 
 

 Then we’ll use the Pole of inaccessibility tool. Let’s look at 
the result and think about why it might be weird/wrong. 
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 Then we’ll create Centroids for our UK local authorities 

layer. Let’s then zoom in to North Ayrshire and figure out 
why they are in the sea.  
 

 After running Point on surface we’ll compare the results to 
our Centroids analysis. This is a good example of where 
different geoprocessing approaches can produce different 
results – but not for every location. 
 

 Now we’ll create a Distance matrix for those places 
identified as being a City in our places layer (we’ll could 
also add a new column to convert the distances to miles 
(using format_number("Distance"  / 1609.34,2)). 

 

 

Use this if you want 
to just find the 10 

nearest places, or 
any other number. 

Just how far is 
Inverness from 

Brighton anyway? 



Taking QGIS to the Next Level                      automaticknowledge 

28 
 

Notes 

I’ll briefly look at the results from the distance matrix and then 
compare it to a 100 mile Newcastle/Hull buffer – because doing 
this kind of thing is helpful. It is a good sense check but it also 
tells us more about the tools we use – in this case what the 
Segments option does in Buffer. 
 
Is Hull within 100 miles of Newcastle? (based on the Ordnance 
Survey data we’re using) 
 

 
 
 
We’re done with the spatial analysis now, but the final point I 
want to make is that when you’re doing any kind of spatial 
analysis it’s wise to a) check the results and b) make sure you 
understand what the tools do. One of the great things about 
QGIS geoprocessing tools is that you get a text description 
within each tool window explaining what it does. Not everyone 
remembers to read these, but it’s important to do so. 

When we use 5 in 
the Segments box 
the answer is ‘no’. 

When we use 500 in 
the Segments box 
the answer is ‘yes. 
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6. My top 5 QGIS Plugins 
This section is about QGIS Plugins. 
 
These are tools written by software developers that add extra 
functionality to QGIS. Things that you can’t currently do with the 
default, built-in features in QGIS are often possible with Plugins. 
 
You can see the full list at the following link – there are more 
than 1,000 and some of them are just amazing.  
 
https://plugins.qgis.org/plugins/ 
 
It really is worth spending some time browsing the Plugins page, 
and sorting by number of downloads to see the most popular 
tools. These are my top 5. 
 
1. MMQGIS – a collection of great vector layer tools. 
2. Globe Builder – turn your flat world into a globe  
3. agis2web – create an interactive web map  
4. Qgis2threejs – create an interactive 3D web map (so cool!) 
5. SRTM-Downloader – NASA elevation data (free, but sign up) 
6. Data Plotly – create D3 charts from your data, in QGIS 
7. TravelTime platform – my go-to for travel time maps + more 
 
You can see that I couldn’t keep my top 5 to just 5 – there are 
just too many good ones. I often use other tools as well but just 
make sure you know where to find them. We’ll explore some of 
these, based on how much time we have left. 
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7. Automating map production with QGIS Atlas 
Now it’s time for the main event. First, let’s just reflect a bit on 
where we’re up to right now, before moving on. 
 

 You can make maps with QGIS  
 You can make them look good  
 You’re now faster at it than you used to be  
 You’re getting pretty good with expressions  
 You’ve learned some great new tricks  

 
Okay then, so now it’s time to move things to the next level  to 
become something of a ‘power user’  who can map the world 

 in a day, in just about any way  - via automated mapping. 
 
The Atlas tool allows you to automate map production in QGIS 
and is AMAZING. This is what we’ll focus on for the rest of the 
session . I’ll go a bit easier on the emojis now as well. 
 
Here’s what we’re going to do (below) – I’ll give you a brief 
summary of what we’ll work towards, then I’ll get us started with 
a follow along demo, and then you can experiment, tinker and 
take it from there. It goes a little something like this. 
 

1. We’ll download the data we need 
2. We’ll start to style our data first (and add a Filter) 
3. Then we’ll turn on the Atlas tool in QGIS 
4. Then we’ll keep working on it with styling and expressions 
5. Then we’ll try to export some maps 
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 If you haven’t done so already, Save whatever you were 
working on previously (e.g. a project with UK data, possibly 
some Plugins as well) and open a New project in QGIS. 

 
 Go to the link below and download the five atlas_ datasets: 

https://automaticknowledge.org/training/data/ 
 

 Now, load them into QGIS – you may notice that if you drag 
and drop them in they display with 1 at bottom and 5 at the 
top, but if you add them via the Data Source Manager they 
will be ordered from 1 to 5 (the correct order). Before 
moving on, just make sure they are ordered with 1 at the 
top, then 2, all the way to 5. Switch 1 and 2? Yes? Why? 
 

 Here’s an explanation of what the layers are: 
atlas_1… – this layer contains country borders. 
atlas_2… – this layer contains world cities. 
atlas_3… – this is world lakes layer. 
atlas_4… – this contains countries + data, for the Atlas. 
atlas_5… – same as 5, but it has more in it (e.g. Greenland). 
 

 Right now, your map will look quite ugly. Rather than spend 
lots of time on styling, download the qml style files for each 
layer from the data/styles folder (right-click and Save link 
as…) and apply them to each layer via Layer Properties and 
the Style button at the bottom, then Load Style…. If your 
layers disappear when you apply the styles, don’t worry – 
they’ll come back! 

Somebody ask me about qml names and paths at this point – it’s a 
nifty trick. 

https://automaticknowledge.org/training/data/


Taking QGIS to the Next Level                      automaticknowledge 

32 
 

Notes 

We can explore what’s going on with the styles later on if we 
have time, and you can investigate further in your own time, but 
for now we’ll focus on creating a series of maps – one for each 
country in the world – that look something like the one below – I 
made this using the data you have now. 
 

 
 
On the next page I’ll walk us through the steps of creating an 
Atlas in QGIS, but almost everything you see above – the map, 
the flag, the data – comes from the Attribute Table of atlas 
dataset 4. The cities are from atlas_2, the borders are from 1, the 
lakes from 3 and the underlying land backdrop from 5. There is 
a filter on my cities layer (add it now – it’s in filter_text.txt in the 
data folder) and the layer styles use quite a few expressions, but 
the whole thing is driven by one main layer – dataset 4. 



Taking QGIS to the Next Level                      automaticknowledge 

33 
 

Notes 

Okay, so let’s follow along as I build up an Atlas that gets 
us somewhere close to what we have above. Then for the 
rest of the time you can experiment further. 
 

 I actually ordered my layers as follows, so make sure yours 
are like this too: 2, 1, 3, 4, 5.  

 
 I used #83b7d9 as the blue colour for the project 

background, so you can do this too now via Project > 
Properties > General. 
 

 Before you go any further, Save your project again – 
appending the page number to the name, as before – e.g. 
qgis_next_level_p.33.  
 

 Go to Project > New Print Layout… and then give it a name 
(e.g. Atlas) and hit OK. 
 

 At this point I normally re-size my page to 320mm x 180mm 
(to match the 16:9 aspect ratio of most screens). You don’t 
have to, but given that most people will view these things 
on a computer or phone, it often makes sense. 
 

 Let’s add a map, then re-size it to take up most of the page 
– like the example above. 
 

 Then add a text box for where the country name will go. 
You can leave it with the default Lorem ipsum text for now. 
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 Now we need to go to the Atlas tab then we tick the 
Generate an atlas box (see screenshot below), and choose 
atlas_4_world_countries_ATLAS as our Coverage layer. 
When you make an Atlas, you need to tell QGIS which layer 
the Atlas is based on – once you do this you can pull data 
from that layer’s Attribute Table into the map layout. 
 

 With the map area selected on 
the main Print Layout page, go 
to the Item Properties tab and 
then scroll down until you can 
see the Controlled by Atlas box 
and then tick it. 
 

 What this will do is pan and zoom 
the map to each individual feature 
(i.e. each row) in the Coverage 
layer. Since our Coverage layer has countries in it, and 
since each row is a country, what this does is put one 
country at a time in the map frame as you advance 
through the Atlas. So now you need to turn the Atlas on! 
 

 Hit the Preview Atlas button (or Atlas > Preview) and watch 
the magic happen . Be patient, it may take a moment. 
 

 To see a preview of each of the different countries, use the 

Atlas Toolbar  e.g. click the forward arrow. 

Make sure you have the Filter on your cities layer – if things are 
running really slowly for you, you could adjust the filter to just show 
capital cities, for example - "capital" = 'primary' 



Taking QGIS to the Next Level                      automaticknowledge 

35 
 

Notes 

Baffled? 
Don’t worry if you’re scratching your head a lot at this point. 
This is a really powerful tool, but it can take a while to figure out exactly 
what is going on. If you need me to walk back through the steps so far, just 
let me know. If you’re almost there but not quite, that’s totally fine too. The 
only really important things so far are that you’ve ticked the Generate an 
atlas box, told QGIS what to use as the Coverage layer, and turned the 
Atlas on by hitting the Preview Atlas button. 

 
 

 Now we’re going to add one of our fields from the Attribute 
Table to our main text box that we already added – this is 
going to be the “Country Name” column and once we add 
this to the text box each time we move to the next  map 
QGIS will pull in the country name of the country shown on 
the map, as if by magic – see the screenshot below. 
 
 

 
 

These are the 
fields from our 
Attribute Table. 

Country names will appear here 
N.B. Open this 
window via the 

Item Properties tab 
for each text Item – 
then click Insert an 

Expression… 
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 The basic principle when using the Atlas is that instead of 
doing things manually, like typing in the name of a country, 
we can generate things automatically by pulling in data 
from the Attribute Table using the Insert an Expression… 
button, deleting the default Lorem ipsum text and then 
adding the name of the field we want to add data from, 
using the Insert Expression dialog. 

 

 Using this principle, we’ll add an image box  and set the 
source of the image via Item Properties  to the 
"ImageURL" column from our Attribute Table – I added a url 
for each country’s flag in svg format to our country 
dataset. A few (e.g. South Africa, Brazil) seem to render 
weirdly in QGIS, so watch out for any quirks. 
 

 After you’ve added a title, map, image (for the flags) see if 
you can also add in figures for GDP and population, as 
shown in my example above. As you know, in the Print 
Layout anything you add is an Item and you edit all Item 
Properties on the tab on the right. 

 
 
Once you’ve added the items, change the text size and/or 
colour where necessary and you should then have something 
like the screenshot below – we can talk about how to add 
other elements after that, and how to format them. The bars 
in my example above are just shapes, sized using our data. 
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The map above is starting to look half decent. When you add 
a number – like population – by default you will probably see 
something like this: 32510453. This is correct, but it’s not very 
easy for us to quickly determine that the population of Peru is 
32.5 million. I prefer to use the latter format for populations. 
 
To format the number as I have above, see below for what 
you’d enter in the box after hitting Insert an Expression… - just 
note that once you hit OK it will have [square brackets] and % 
signs around it in the Main Properties whitebox. I’ve shown you 
on the next page what I mean – follow the 1, 2, 3 text circles. 
 

 format_number("Y2019"/1000000,1) || ' million' 
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Remember this 
Before the Atlas becomes live in QGIS, you need to activate it. 
As we saw above, this is done via the Preview Atlas button (or Atlas > 
Preview) . 
 
What you should also know is that when you re-open a QGIS project with 
an Atlas in it, you will need to hit the Atlas button again, otherwise you’ll just 
see something that looks broken – e.g. instead of seeing a country name 
you may just see the name of the column (“Country Name”) in our case. 
 
This sometimes catches people out, so I thought I’d add this warning in. 

 
You should be making a nice bit of progress with the Atlas now, 
but either way, remember to save your project.   

Text that I 
actually 
entered. 

How it appears in 
Main Properties. 

The end result! 

1 

2 

3 
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When it comes to the Atlas in QGIS, the real power is unleashed 
when you set it to export all your images. This is done via Atlas > 
Export Atlas as Images… (note that you can also export to pdf or 
svg). You can also export individual Atlas frames as well, via the 

Export as image button . My normal method is to export all 
images as 300dpi png files. 
 
Before exporting your Atlas it’s a good idea to save your 
project, in case of unexpected crashes – sometimes we might 
try to export more than our computer can handle! 
 
We can also use some other options to configure our Atlas – e.g. 
we can use expressions to tell QGIS how to name our Atlas files 
(after all, if they’re all called Output_1, Output_2 etc. we’ll have 
trouble finding the files for the country we want). 
 
At the top of the next page you’ll see that in my Atlas tab I have 
used Country Name as the Page name. I have also chosen not 
to include countries where there is no GDP data for 2019, and I 
have sorted my Atlas by the GEOUNIT column, so that countries 
are in alphabetical order.  
 
For the file name I don’t want spaces so I have used the 
replace() function to replace spaces with underscores and then 
added 300dpi to the file name, so I can see from the file name 
exactly what the resolution is. The export format I chose is png 
and I have unticked the Single file export when possible box. 

Instead of using the drop-down lists to find a field to use, you can 
actually just manually type in the name of the field if you know it – 
(e.g. start typing country to find the Country Name field) – this saves 
time when our Coverage layer has tons of fields. 
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 When you’re happy with your layout, export an individual 
Atlas image via Layout > Export as Image. View the 
image via the green file path bar when it appears. 

 
 Once this works, let’s export a file for countries beginning 

with A, by entering this into the Filter with box   
left("Country Name" ,1) = 'A' then Atlas > Export Atlas as 
Images. It’s best not to try to export the entire Atlas now 
but once you’ve exported a few, check the results. 

 
That’s the basics of the Atlas – now it’s time to experiment. 

If nothing happens when 
you do this, turn the Atlas 
off and on again via the 

Preview Atlas button. 

We’re using an expression to tell QGIS 
how to name the files – and we’re 

choosing the png format. I added lower 
so the file name is all lower case. 

Filter with allows us to select what is 
included in our Atlas, and Sort by sets 

the order of pages – very useful. 

Sometimes with the Atlas you need to hit the forward or back button 
to see a change take effect – or sometimes refresh the page. 
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8. Customising and perfecting your Atlas 
This is the final section of the workbook, and the idea is (all 
being well, and time-permitting) that we work on customising 
and perfecting our Atlas and then try and export a few more 
images. Feel free to go back to other bits as well if you like. 
 
Here are a few tips, thoughts and ideas that might be useful. 
 

 I use the colour picker to select nice colours from a web 
browser. Sometimes I literally type in ‘nice blue colour’ or 
‘nice reds html’ and then go to the image results in Google. 
This works well a lot of the time. I also pick colours from 
organisations – e.g. if I’m making election maps I use the 
exact colours from political party websites by using the 
QGIS colour picker – after all, some colours are hard-wired 
in our brains so there is no need to use different ones. 

 
 Always add a ‘data sources’ note – at least enough so that 

someone can use the information to find your source, but 
possibly even a full url. My World Bank datasets are very 
easy to find on Google so I’ve just added in that as the 
source in our example. 
 

 When we make a map it’s often useful to be able to know 
exactly when it was made – so for mine I used this 
expression in a text box at the top right of my map: 'Map 
created: '  || format_date(   now(),'ddd d MMM yyyy','en' ). 
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 See below for how to add in text that is a mix of text typed 
in plus text pulled in from your Atlas Coverage layer. 
Basically, anything in between single quotes will appear as 
it is written. To add in a value from your Attribute Table in 
the middle of it (and you can add as many as you like) you 
just need to separate it with the double || pipe symbol. 
When you want to write something with an apostrophe in it, 
you need to add in two – as in it’’s below.  
 
'This text box is intended to demonstrate how you can mix 
any text you want with data from your Atlas coverage 
layer. The map of ' ||  "Country Name"   || ' to the left may not 
be perfect, but it''s a decent start. Boundaries shown on the 
map are sourced from Natural Earth and are not indicative 
of any territorial claims.' 

 
 I can demo adding the inset map if there’s time – it’s 

shown at a fixed global zoom level using the Overviews tool 
– that’s where the black locator box comes from. The small 
map frame has the overview added to it, via the green plus 
sign in Overviews in the map frame’s Item Properties. 

 
 You can also adjust/edit/tweak the expressions and filters 

that I provided for you. This is a good way to figure out 
what’s going on. In particular, pay attention to these 
expressions: $id  =  @atlas_featureid and  NOT $id  =  
@atlas_featureid – they tell QGIS to either show only the 
active Atlas feature, or everything but the active feature.  
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 For my cities layer, I added a Rule-based symbology so 

that QGIS displays the city points differently, depending 
upon whether they intersect the current Atlas feature – you 
can see this in the atlas_2_world_cities_natranks Layer 
Properties when you view the Symbology of it. 
 

 This next expression tells QGIS to display features that 
intersect the current Atlas feature: intersects($geometry, 
@atlas_geometry ). It then has a style applied to it. 
 

 This one tells QGIS to display features that do NOT intersect 
the current Atlas feature, and they are also styled: NOT 
intersects($geometry, @atlas_geometry ) AND  "capital" = 
'primary' AND  "CITYRANK"  <= 5. 
 

 And the expression I used as a Filter on the cities layer? See 
below for the text and also an explanation:  
 
NOT "city" IN 
('Roodepoort','Randburg','Vereeniging','Lanús','Callao','Klang','
Shah Alam','Petaling 
Jaya','Birstall','Depok','Tangerang','Bekasi')  AND "CITYRANK" 
<= 10 AND "population" >= 200000 OR "capital" IN ('primary')  
OR "city" IN ('Honolulu','Anchorage') 
 
The list of places after the NOT bit is all places I want to 
exclude – either because they shouldn’t be there or 
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because they are obscuring more important places. The 
“CITYRANK” bit makes sure I’m only ever displaying, at most, 
the top 10 cities by population within a country – I added 
this column in myself in Excel. The “population” bit ensures 
I’m only displaying cities with a reasonably high population 
and the OR “capital” bit makes sure I’m displaying all 
country capitals. The cities after OR “city” IN bit at the end is 
my way of adding in cities that wouldn’t otherwise appear 
on the map – in this case Honolulu and Anchorage. They 
are not main US capitals and although they have more 
than 200,000 people, they are not among the top 10 most 
populous US cities, so they don’t appear by default. 

 
You can use an expression like the one below to add ‘no data’ in 
places where you have missing data for GDP, or other variables. 
 
 

CASE  
WHEN "GDPCAP2019" IS NOT NULL THEN 
 '$' || format_number("GDPCAP2019" ,0) 
  ELSE 'no data' 
  END 

 
 

 In some cases the Atlas page looks a little sparse, so you 
may want to consider getting (e.g.) some road or rail line 
data and adding that in (from Natural Earth). 
 

Translation: in cases 
where my GDP 2019 

column has data in it 
(aka IS NOT NULL) then 
please format it with a 

thousand separator and 
zero decimal places, with 

a dollar sign before it. 
Otherwise, just put in the 

words ‘no data’. Ta. 
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Remember this 
Anything we create here – or elsewhere – is only as good as our data. 
 
For example, see the Russia map, the US one, or the Norway one – they 
need some work. Also, what about Taiwan’s data? That’s due to how the 
World Bank approach it – they don’t publish Taiwan data. I have manually 
added in some population data for Taiwan but there is no GDP data. 

 
There is a lot in this workbook – on purpose.  
I want you to come away with new skills today, but then keep 
the workbook handy so that you can build on these skills. 
I absolutely don’t expect everyone to have fully absorbed 
everything by the end of the day – but if you have, great! 
 
My hope is that you’ve learned about a selection of useful new 
tools that will enable you to be more productive, ask new and 
interesting geographic questions, and even save yourself some 
time (and pain) while doing so.  
 
I also hope you have enough knowledge to begin exploring the 
things you could do with the Atlas tool – it really does open up 
all kinds of possibilities for analysis and visualisation. 
 
I don’t like to leave people high and dry after a training session 
so if you’re stuck or need me to clarify anything, feel free to get 
in touch – email, website contact form, Twitter DM, whatever. 
 
Thanks for joining in!  
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9. Credits 
 
QGIS - QGIS is a user friendly Open Source Geographic Information System 
(GIS) licensed under the GNU General Public License. QGIS is an official 
project of the Open Source Geospatial Foundation (OSGeo). 
https://www.qgis.org/en/site/about/index.html  
 
Natural Earth – ‘no permission is needed to use Natural Earth data’. All 
versions of Natural Earth raster + vector map data found on this website 
are in the public domain. 
https://www.naturalearthdata.com/about/terms-of-use/ 
 
SimpleMaps – World Cities Database (Basic), used under the Creative 
Commons Attribution 4.0 licence. 
https://simplemaps.com/data/world-cities 
 
World Bank – Population data, used under the Creative Commons 
Attribution 4.0 licence. 
 
https://data.worldbank.org/indicator/SP.POP.TOTL 
 
Emojis are from Twemoji, at twemoji.twitter.com, licenced under the CC-BY 
4.0 licence. 
https://twemoji.twitter.com/ 
 
Poppins Font - Designed by Indian Type Foundry, Jonny Pinhorn, licenced 
under the Open Font Licence. 
https://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=OFL 
 
Flags – the svg files we used in the Atlas task were from Wikipedia. 
https://en.wikipedia.org/wiki/Gallery_of_sovereign_state_flags 
 

https://www.qgis.org/en/site/about/index.html
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
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10. Useful links 
Natural Earth – the best source for easy-to-use global map data, e.g. 
countries, places, states, roads, coastlines and much more. 
https://www.naturalearthdata.com 
 
simplemaps – world cities csv files, with lat/long coordinates. This is a 
great source for place name data. 
https://simplemaps.com/data/world-cities 
 
Sentinel-2 cloudless – for adding satellite imagery to QGIS. Right-click 
WMS/WMTS in the QGIS browser panel, then click New Connection… add 
Sentinel-2 cloudless to the Name and the second url below to the URL field. 
https://s2maps.eu/ 
https://tiles.maps.eox.at/wms?service=wms&request=getcapabilities 
 
OS OpenData Downloads (Ordnance Survey) – a huge amount of free, 
open geospatial data are now available from Ordnance Survey via their 
Open Data Hub. The data covers Great Britain and no registration is 
required. 
https://osdatahub.os.uk/downloads/open 
 
ONS Geography Portal (UK) – see the Boundaries section of this website 
for a wide range of UK boundary data. This site includes data for the whole 
of the UK, whereas Ordnance Survey data only covers Great Britain. A great 
resource. 
https://geoportal.statistics.gov.uk/ 
 
QGIS Documentation – the official help docs from the people who make 
QGIS. 
https://www.qgis.org/en/docs/index.html 
  

https://www.naturalearthdata.com/
https://s2maps.eu/
https://tiles.maps.eox.at/wms?service=wms&request=getcapabilities
https://osdatahub.os.uk/downloads/open
https://www.qgis.org/en/docs/index.html
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Back page cheat sheet 
These are things I use myself – to make things work faster, better, smoother.  
 CTRL+Tab turns panels on/off so the map area is full screen width. 
 Select some features, Edit > Copy Features then Edit > Paste Features As a new 

temporary layer (called a ‘scratch’ layer) or a new vector layer. 
 F11 for full screen mode, F1 for QGIS User Guide, F6 to open Attribute table (on Windows). 
 CTRL+Shift+Tab for full screen map mode (on Windows). Same again to undo. 
 Change projection for project (it doesn’t alter any data) via EPSG button, bottom right. 
 Black is too harsh, try #222222 / RGB 34, 34, 34 instead. Go beyond default colours! 
 Where is your layer stored? Double-click a layer, go to Information and see Path. 
 Turn on the thousand separator (1,000 vs 1000) – Settings > Options > General, tick box. 
 Want to save the position of your map? Use View > New Spatial Bookmark. 
 Print Layout looking fuzzy? Just hit refresh and that will fix it. 
 Print Layout page not zooming to full extent? Re-size your page, then reset to original. 
 Save your most commonly used data source paths as Favorites in the Browser. 
 When styling layers, you don’t have to use only the columns you already have – e.g. 

you can style based on calculations or even by extracting portions of text. 
 Hey, my lovely XYZ base map looks a bit fuzzy! Set projection to EPSG:3857. 
 Hey, my joined layer has weird column header names! Go back into Joins, and edit the 

join so that the Custom Field Name Prefix is ticked and the box is blank. 
 How do you do those glowing lines/polygons? That’s via Blending mode in Symbology. 
 Help! My side panel things have disappeared. Go to View > Panels. 
 Use Inverted polygons with a filter and a satellite base layer to create nice area maps 

– make layer white/black and use about 75% Opacity. 
 Go to Processing > History to view or re-run your recent geoprocessing tasks. 
 A general carto tip: try to make your map as simple as possible, remove any junk. 
 Type world into the Coordinate box if you want a world countries layer to use. 
 Use a 16:9 aspect ratio if your maps are mainly for screens (e.g. 320mm x 180mm). 
 Map a list of x and y coordinates quickly via Delimited Text in Data Source Manager. 
 Drag and drop files from your file browser directly into QGIS (e.g. shp, gpkg etc). 
 You can add layers via the WMS/WMTS option in Browser. Just Google it. 
 Want to save/re-use a map style for a layer? Layer Properties > Style > Save Style…  
 If you give the qml file the same name as a layer file and put it in the same folder as 

the file then when you add it to QGIS that style will be applied by default. 
 Learn about Draw effects! Use them to add a glow or a shadow to features. 
 View > Preview Mode to see your map in colour-blind safe modes or greyscale. 
 Best Plugins? MMQGIS, SRTM Downloader, Build Globe View, Qgis2threejs, qgis2web. 
 Add base maps via XYZ Tiles in Browser panel. OpenStreetMap is there by default. 


